poj 1509 Glass Beads 最大最小表示板题

缘起

继续学习最大最小表示这种精巧的算法~ poj 1509 Glass Beads

分析

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
给你一串字符串,但是这串字符串是环形的,让你找个位置切开,使得它的字典序最小.

【输入】
多样例. 第一行是样例数. 然后每个样例占据一行——不超过10000个字符的仅由小写字母构成的字符串。

【输出】
对每个样例, 输出最小表示ms(具体含义参见【1】)

【样例输入】
4
helloworld
amandamanda
dontcallmebfu
aaabaaa

【样例输出】
10
11
6
5

【限制】
3s

学会了【1】,就是最大最小表示的裸题~ 不解释, 上板子~ 比【1】还裸~

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
//#include "stdafx.h"
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
//#define LOCAL
const int maxn = 10005;
char s[maxn];
int len;

int getmin()
{
int i = 0,j=1,k = 0, t;
while (i<len &&j<len&&k<len)
{
t = s[(i+k)%len]-s[(j+k)%len];
if (!t)
{
++k;
continue;
}
t>0?i+=k+1:j+=k+1;
if (i==j)
{
++j;
}
k = 0;
}
return min(i,j)+1;
}

int main()
{
#ifdef LOCAL
freopen("d:\\data.in", "r", stdin);
// freopen("d:\\my.out", "w", stdout);
#endif
int kase;
scanf("%d", &kase);
while(kase--)
{
scanf("%s", s);
len = strlen(s);
printf("%d\n", getmin());
}
return 0;
}

ac情况

Status Accepted
Memory 112kB
Length 635
Lang C++
Submitted 2019-10-30 16:25:12
Shared
RemoteRunId 21004834

参考

【1】https://yfsyfs.github.io/2019/10/30/hdu-2609-How-many-最大最小表示板题/