zoj 2588 burning bridge 带重边的边bcc和割边

缘起

日常浪费生命~ zoj 2588 burning bridge

分析

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
求一个无向连通图的桥(可能存在重边),输出割边的数目,并按顺序输出割边的序号(按输入的顺序)。

【输入】
多样例, 每行开始于一个N和M, 表示点的个数和边的个数.
2 <= N <= 10 000, 1 <= M <= 100 000
然后M行,每行2个不同正整数

【输出】
对每个样例,输出桥的数量,然后输出割边的序号

【样例输入】
2

6 7
1 2
2 3
2 4
5 4
1 3
4 5
3 6

10 16
2 6
3 7
6 5
5 9
5 4
1 2
9 8
6 4
2 10
3 8
7 9
1 4
2 4
10 5
1 6
6 10

【样例输出】
2
3 7

1
4

【限制】
5s

只要真正搞懂了【1】和【2】(【1】讲思想,【2】讲模板). 此题根本就是水题.

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
//#include "stdafx.h"

#include <stdio.h>
#include <vector>
#include <string.h>
#include <algorithm>
using namespace std;
//#define LOCAL

const int maxn = 10005, maxm = 100005;
int n,m, id, low[maxn], timestamp[maxn], top, ans[maxn],t;
struct Edge
{
int to, id;
Edge(int to, int id):to(to),id(id){}
};
vector<Edge> g[maxn];

typedef vector<Edge>::iterator vit;

void dfs(int cur, int fa)
{
timestamp[cur] = low[cur] = ++t;
for (vit x = g[cur].begin(); x!=g[cur].end(); x++)
{
if (!timestamp[x->to])
{
dfs(x->to, x->id);
low[cur] = min(low[cur], low[x->to]);
if (low[x->to]>timestamp[cur])
{
ans[top++] = x->id;
}
}
else if (x->id!=fa)
{
low[cur] = min(low[cur], timestamp[x->to]);
}
}
}

int main() {
#ifdef LOCAL
freopen("d:\\data.in", "r", stdin);
//freopen("d:\\my.out", "w", stdout);
#endif
int kase;
scanf("%d", &kase);
while(kase--)
{
id = top = t= 0;
memset(timestamp, 0, sizeof(timestamp)), memset(low, 0, sizeof(low));
scanf("%d%d", &n, &m);
for (int i = 1; i<=n;i++)
{
g[i].clear();
}
while(m--)
{
int a,b;
scanf("%d%d", &a, &b);
id++;
g[a].push_back(Edge(b, id)), g[b].push_back(Edge(a, id));
}
dfs(1,0);
sort(ans, ans+top);
printf("%d\n", top);
for (int i = 0;i<top; i++)
{
if (i)
{
putchar(' ');
}
printf("%d", ans[i]);
}
if (top) // 这里PE无数次~
{
puts("");
}
if (kase)
{
puts("");
}
}
return 0;
}

ac情况

Submit Time Judge Status Problem Compiler Run time(ms) Run Memory(KB) User
2019/9/10 19:20:39 Accepted 2588 C++ (g++ 6.4.0) 279 9384 影法師

TestCaseResult:

Name Result Time(ms) Memory(KB)
0 Accepted 279 9384

如【1】所言,带不带重边本题算法都能适用~ 因为只是求割边而已. 不涉及边bcc的收集

参考

【1】https://yfsyfs.github.io/2019/09/10/poj-3352-Road-Construction-%E4%B8%8D%E5%B8%A6%E9%87%8D%E8%BE%B9%E7%9A%84%E8%BE%B9bcc/

【2】https://yfsyfs.github.io/2019/09/10/lightoj-1026-Critical-Links-%E5%89%B2%E8%BE%B9/