hdu 1269 迷宫城堡 scc

缘起

日常浪费生命 hdu 1269 迷宫城堡

分析

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
为了训练小希的方向感,Gardon建立了一座大城堡,里面有N个房间(N<=10000)和M条通道(M<=100000),每个通
道都是单向的,就是说若称某通道连通了A房间和B房间,只说明可以通过这个通道由A房间到达B房间,但并不说明通
过它可以由B房间到达A房间。Gardon需要请你写个程序确认一下是否任意两个房间都是相互连通的,即:对于任意
的i和j,至少存在一条路径可以从房间i到房间j,也存在一条路径可以从房间j到房间i。

Input
输入包含多组数据,输入的第一行有两个数:N和M,接下来的M行每行有两个数a和b,表示了一条通道可以从A房间来到B房间。文件最后以两个0结束。

Output
对于输入的每组数据,如果任意两个房间都是相互连接的,输出"Yes",否则输出"No"。

Sample Input
3 3
1 2
2 3
3 1
3 3
1 2
2 3
3 2
0 0

Sample Output
Yes
No

scc裸题——就是判断是不是只有一个scc. 直接上tarjan.

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
//#include "stdafx.h"

#include <stdio.h>
#include <string.h>
#include <stack>
#include <algorithm>
using namespace std;
//#define LOCAL

int n,m, head[10005], cnt, timestamp[10005], low[10005], t, sccnum;
bool ins[10005];
stack<int> s;

struct Arc
{
int from, to, nxt;
}g[100005];

void addArc(int a, int b)
{
g[cnt].from = a, g[cnt].to = b, g[cnt].nxt = head[a];
head[a] = cnt++;
}

void dfs(int i)
{
timestamp[i] = low[i] = ++t;
s.push(i), ins[i] = true;
for (int h = head[i],to; ~h; h = g[h].nxt)
{
to = g[h].to;
if (!timestamp[to])
{
dfs(to);
low[i] = min(low[i], low[to]);
}
else if (ins[to])
{
low[i] = min(low[i], low[to]);
}
}
if (low[i] ==timestamp[i])
{
if (++sccnum>1) // 如果多余1个scc就直接返回
{
return;
}
int j = i;
do
{
j = s.top(), s.pop(), ins[j] = false; // 本题不需要缩点
} while (j!=i);
}
}

bool tarjan() // 返回true表示scc个数>1, false 表示=1
{
for (int i = 1; i<=n; i++)
{
if (!timestamp[i])
{
dfs(i);
if (sccnum>1)
{
return true;
}
}
}
return false;
}

int main() {

#ifdef LOCAL
freopen("d:\\data.in", "r", stdin);
//freopen("d:\\my.out", "w", stdout);
#endif
while(scanf("%d%d", &n, &m), n||m)
{
memset(head, -1, sizeof(head));
memset(ins, 0, sizeof(ins));
memset(timestamp, 0, sizeof(timestamp));
memset(low, 0, sizeof(low));
while(!s.empty())
{
s.pop();
}
cnt = t = sccnum = 0;
while(m--)
{
int a,b;
scanf("%d%d", &a, &b);
addArc(a,b);
}
tarjan()?puts("No"):puts("Yes");
}
return 0;
}

ac情况

Status Accepted
Time 78ms
Memory 3416kB
Length 1512
Lang G++
Submitted 2019-09-08 13:04:15
Shared
RemoteRunId 30530212