poj 2392 Space Elevator 多重背包

缘起

日常浪费生命 poj 2392 Space Elevator

分析

题意

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
有一头奶牛要上太空,他有k种石头,每种石头的高度是hi,但是不能放到ai之上的高度,并且这种石头有ci个
将这些石头叠加起来,问能够达到的最高高度。

【输入】
第一行是k(1 <= K <= 400) 然后是K行,每行是三个数
hi,ai,ci
1 <= h_i <= 100
1 <= c_i <= 10
1 <= a_i <= 40000

【输出】
用这些石头最高搭建的塔能有多高.

【样例输入】
3
7 40 3
5 23 8
2 52 6

【样例输出】
48

【限制】
1s

和【1】相比,本题是带限制条件的多重背包. 从贪心的角度而言,ai比较小的石头肯定要优先考虑. 所以本题的解法应该是先按照ai升序排序. 然后按照这个顺序进行多重背包算法. 当然,因为有了ai限制. 所以dp方程多少要变化一些——即这种石头不能参与ai以上的dp背包,下面的代码有不清楚的地方,参见【1】

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
//#include "stdafx.h"

#include <stdio.h>
#include <algorithm>
using namespace std;
//#define LOCAL

int n,sum;
bool dp[400005]; // 最高不超过40w
struct B
{
int h, c,a;
bool operator<(B o)
{
return a<o.a;
}
}b[405];

void zp(int h, int a) // 带限制的01背包
{
for (int i = min(sum, a); i>=h; i--) // 因为限制a的缘故, 不能参与大于a的dp
{
dp[i] = dp[i] || dp[i-h];
}
}

void cp(int h, int a) // 带限制的完全背包
{
for(int i = h; i<=min(sum, a); i++)
{
dp[i] = dp[i] || dp[i-h];
}
}

void mp(int h, int c, int a) // 带限制的多重背包
{
if (h*c>=min(a,sum))
{
cp(h, a);
}
else
{
int k = 1;
while(k<c)
{
zp(h*k,a);
c-=k;
k<<=1;
}
zp(c*h,a);
}
}

int main()
{
#ifdef LOCAL
freopen("d:\\data.in", "r", stdin);
//freopen("d:\\my.out", "w", stdout);
#endif
scanf("%d", &n);
dp[0] = true;
for (int i = 1;i<=n;i++)
{
scanf("%d%d%d", &b[i].h, &b[i].a, &b[i].c);
sum+=b[i].h*b[i].c;
}
sort(b+1, b+n+1);
for (int i =1;i<=n;i++)
{
mp(b[i].h, b[i].c, b[i].a);
}
for (int i = sum; ~i; i--)
{
if (dp[i])
{
printf("%d\n", i);
break;
}
}
return 0;
}

ac情况

Status Accepted
Time 125ms
Memory 212kB
Length 1063
Lang C++
Submitted 2019-08-28 21:37:43
Shared
RemoteRunId 20813705

参考

【1】https://yfsyfs.github.io/2019/08/28/poj-1014-Dividing-%E5%A4%9A%E9%87%8D%E8%83%8C%E5%8C%85%E4%B9%8B%E4%BA%8C%E8%BF%9B%E5%88%B6%E4%BC%98%E5%8C%96/