hdu 1874 畅通工程续 spfa模板

缘起

日常水题 hdu 1874 畅通工程续

题目是中文的 QAQ

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
某省自从实行了很多年的畅通工程计划后,终于修建了很多路。不过路多了也不好,每次要从一个城镇到另一个城镇时,都有许多种道路方案可以选择,而某些方案要比另一些方案行走的距离要短很多。这让行人很困扰。 

现在,已知起点和终点,请你计算出要从起点到终点,最短需要行走多少距离。

【输入】
本题目包含多组数据,请处理到文件结束。
每组数据第一行包含两个正整数N和M(0<N<200,0<M<1000),分别代表现有城镇的数目和已修建的道路的数目。城镇分别以0~N-1编号。
接下来是M行道路信息。每一行有三个整数A,B,X(0<=A,B<N,A!=B,0<X<10000),表示城镇A和城镇B之间有一条长度为X的双向道路。
再接下一行有两个整数S,T(0<=S,T<N),分别代表起点和终点。

【输出】
对于每组数据,请在一行里输出最短需要行走的距离。如果不存在从S到T的路线,就输出-1.

【样例输入】
3 3
0 1 1
0 2 3
1 2 1
0 2
3 1
0 1 1
1 2

【样例输出】
2
-1

【限制】
Time limit 1000 ms
Memory limit 32768 kB

【来源】
2008浙大研究生复试热身赛(2)——全真模拟

spfa裸题. 打板子! 关于spfa不懂的话,参见【1】(spfa就是bellman-ford)

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
//#include "stdafx.h"

#include <stdio.h>
#include <string.h>
#include <queue>
using namespace std;
//#define LOCAL

int n,m, head[205], cnt,d[205],s,t;
bool isinq[205];
struct Arc
{
int from, to, nxt, len;
Arc(){}
Arc(int from, int to, int nxt, int len):from(from), to(to), nxt(nxt), len(len){}
}g[2005];

void addArc(int a, int b, int x)
{
g[cnt] = Arc(a,b,head[a], x);
head[a]=cnt++;
g[cnt] = Arc(b,a,head[b],x);
head[b] = cnt++;
}

int spfa()
{
queue<int> q;
q.push(s);
isinq[s] = true;
while(!q.empty())
{
int front = q.front();
q.pop();
isinq[front] = false;
for (int i = head[front]; ~i; i = g[i].nxt)
{
int to = g[i].to;
if (d[to]>d[front]+g[i].len)
{
d[to] = d[front]+g[i].len;
if (!isinq[to]) // 如果已经在队列中, 不需要再次入队
{
isinq[to] = true;
q.push(to);
}
}
}
}
return d[t]==0x3f3f3f3f?-1:d[t];
}

int main()
{
#ifdef LOCAL
freopen("d:\\data.in", "r", stdin);
//freopen("d:\\my.out", "w", stdout);
#endif
while(~scanf("%d%d", &n,&m))
{
memset(head, -1, sizeof(head));
cnt = 0;
while(m--)
{
int a,b,x;
scanf("%d%d%d", &a, &b, &x);
addArc(a,b,x);
}
scanf("%d%d", &s, &t);
memset(d, 0x3f, sizeof(d));
d[s] = 0;
printf("%d\n", spfa());
}
return 0;
}

ac情况

30394710 2019-08-22 20:45:54 Accepted 1874 15MS 1284K 1333 B G++ yfsyfsyfs

参考

【1】https://yfsyfs.github.io/2019/05/27/bellman-ford%E7%AE%97%E6%B3%95%E4%B9%8B%E9%98%9F%E5%88%97%E4%BC%98%E5%8C%96/